• I play mostly on my main machines at home and my laptop which are all Windows. However, thought i would install triple A here at work and play. I am able to open triple.exe and select which ever game i wish to play and open a new game.

    However, when i click on one my league game files posted in our forums, no matter how i try i am unable to load the saved .tvsg file.

    I have updated all teh .deb and sudo files i can find. When i open it on the Linux machine, it stays in a archived folder, it will not let me extract it. I open the triplea.exe file with wine and i have been able to open it with iced tea launcher. However, the single saved file from the website i get error after error, however 3/4 of them are archived file not supported. I have googled it to the end of the earth and cant find what im missing.

    Any help would be great, if you dont want to post on here feel free to PM me.


  • message i get no matter how i try and open or extract it.

    Screenshot at 2016-04-16 175359.png

  • Just to understand:

    You are on a Linux machine and use WINE to open the Windows-Version of TripleA?
    Doesn’t the Linux-version of TripleA work for you?


    Just unzip the file to any directory and execute the command

    (Be sure to have the latest JRE installed before.)

    And concerning your tsvg-problems:

    It looks like tsvg-files are not registered with your OS. I don’t know that much about Linux (with or without WINE) so I cannot help here.
    But at least you should be able to open all the savegames from inside TripleA via the “Load saved game…”-button.

    HTH :-)

  • Yes,

    Wine opens triple A and all the games work great.

    When i try to unzip or extract the file from our forum pages i get the same message. “file not supported” from the archive manager.

    Also i tried to open the game, then load from the saved copy, however i am unable to unzip or extract it to even try it.

    thanks for your help by the way!

  • Also,

    I selected the file still wrapped after clicking on one from my forum game and saved it.

    Then went into properties and tried to have it always open by the windows.exe in my triple A folder. Which is what i use wine with to open the game. I tried to select the game, and when i went to apply for the file type i get this…


  • In fact there is nothing to unzip or extract. You don’t unzip or extract anything when using Windows, either.

    Just load the savegame-file (*.tsvg) into TripleA… that’s all.

    Start TripleA, hit “Load Save Game”, choose the savegame (*.tsvg-file), click “open” and you are done.

    Don’t forget: TripleA is a Java game. The triplea.exe (Windows) as well as the triplea_unix.sh (Linux) are only OS-dependent launchers for the Java application (which is the triplea.jar to be found in the “bin”-subfolder). It is the triplea.jar that is executed with Java, then.

  • I get what your saying, however when i go to select a saved game no .tsvg files show up. And in the file type option it does say .tsvg file, but no files are listed, hence the need to do something different. Think perhaps they need renamed to .jar? They just refuse to be there after i download, open game and try to select it from download file. Think its directory based? maybe i need to save it in the triple A folder instead of downloads.

  • Hmmm… let’s try to sort that out.

    What I see from your pictures is that there IS a triplea_37705_Ita7.tsvg file in a Downloads-folder that is a subfolder of the Desktop-folder, that is a subfolder of your personal directory.

    So when you open Triple A and hit the “download saved game”-button… to which directory/folder does TripleA point then? Is it the “savedGames”-folder? Or any other folder? Did you try browsing to your Downloads-folder mentioned above from that point on?

  • It points to the saved game folder, however i then change it because of course there is nothing in there on this machine. When i download the files from the forums they go to downloads by default. I change directories when I try and open a saved game but they wont display the .tsvg files. Its just blank.

  • I am trying to move the file into the saved game directory but dont see anything in folder triple a labeled as saved games……

  • Next try:

    1. Start TripleA
    2. Hit the button “Engine Preferences” on the right side
    3. Hit the button “Open User Maps and Savegames Folder”
    4. Move the downloaded savegame (tsvg) file into exactly the “savedGames”-Folder that becomes visible there
    5. Restart TripleA
    6. Hit the button “Load Saved Game”
    7. Your file should be there - select it and go…

    Good luck  :-)

  • still no dice….

    ~/Desktop $ cd triplea_1_8_0_9

    ~/Desktop/triplea_1_8_0_9 $ ls

    assets        license                            system.ini
    bin            MacOS_users_read_this_first.txt    triplea.exe
    changelog.txt  maps                                triplea_mac_os_x.sh
    dice_servers  old                                TripleA_RuleBook.pdf
    doc            readme.html                        triplea_unix.sh
    gradlew.bat    run-headless-game-host.sh          triplea_windows.bat
    icons          run-headless-game-host-windows.bat

    ~/Desktop/triplea_1_8_0_9 $

    That is through the OS command line, here is the location for some reason via list form…

    name/saves/games/strategy/triplea/ according to the program when i open triplea they are suppose to be in the above directory, however i never created a strategy directory. Something is moving these saves auotmatically with this linux system.

  • @ktylu:

    name/saves/games/strategy/triplea/ according to the program when i open triplea they are suppose to be in the above directory, however i never created a strategy directory. Something is moving these saves auotmatically with this linux system.

    And you can’t move the saves back to the said directory?
    Or browse to the directory the saves are in after downloading from inside TripleA?

    If the answer is “no” to both questions, you should ask your system admin.
    You said you are at work, so maybe they don’t want you to do that. Many employers strictly interdict using personal/noncorporate software at work and have some sort of software protection, too, to protect office computers from viruses, trojans and other malware.

    But you know the rules at your place of work, I am just brainstorming…

  • I am the network admin at work sir  :roll:

    Thats why this is bothering me, i was able to get it to download from the forum just now however when it shows up to launch it asks me to pick a program. I select the triplea.exe and of course it crashes because it takes wine to load that.

    I need to somehow read both files from wine… one after the other, but their is no " open with " inside of triple a… i hope that makes sense…

    i moved the saved file to the directory under triple a and that did not work either. Im wondering if it is because i have the triple a directory saved on the desktop… something is not pointed right…

  • @ktylu:

    I am the network admin at work sir  :roll:

    So why do you use Wine at all, then? You don’t need Wine if you start TripleA via ./triplea_unix.sh
    as I indicated in my first answer.

    Inside TripleA you don’t need any “open with”…
    I seem to fail to understand what you want: Doubleclick on the *.tsvg from your Mate-desktop to start TripleA with Wine under Linux?
    Do you act like this when using Windows, too?

    Why not start TripleA, hit “Load saved game”, mark the savegame.tsvg (from whereever it is located) and hit the “open”-dialogue button?

    Anyway - we are turning in circles. I obviously fail to understand what you are doing or trying from what you are writing.

    Another idea is to ask in the TripleA development forum:


    Good luck  :-)

  • Ill screenshot this in steps so those can see.

  • Opening from browser in Linux, you have to choose what to open with like in Windows, no option for triple A. Only windows helpers, even though you will see its installed.

    Opening from Windows.exe triple A icon, the game works just fine no errors.

    Choosing saved game, or selecting where the file is located folder wise, does not show me .tsvg files.

  • Thank you for the illustration.

    I don’t know if it helps but I will comment on what I am seeing.

    First image:

    We are in Linux. When clicking on the savegame.tsvg file from the browser the “You have chosen to open-dialogue” appears. The tsvg-file is unknown and there is no Helper Application for it.

    This is the expected behaviour. As I said before, neither TripleA nor tsvg-files are in any way registered with your Linux-OS. When you execute the triplea.exe using WINE in Linux, you just launch the Java-program TripleA using a windows-launcher. Instead you should use “Save file” in this (above mentioned) dialogue to download the savegame and manually load it from inside TripleA after starting TripleA.

    Second image:

    You use TripleA.exe for Windows to launch the Java-program TripleA with Wine in Linux. So far so good.

    Third image:

    You have started TripleA and want to load a savegame. You do not have or cannot find a tsvg-file in the shown directory/folder.
    If you had chosen “Save file” in the first image’s dialogue, you would have the savegame inside the folder, that you would have defined just before saving. In the shown “open” dialogue, just change to the directory/folder indicated for saving and your tsvg-file will be there.

    HTH :-)

    (Edit: typos)

  • I did try the above procedure, and still getting no where…

    However, I am wondering if i download the linux version from here if it will fix my issue…

    I will fine out monday!


  • @ktylu:

    I did try the above procedure, and still getting no where…

    However, I am wondering if i download the linux version from here if it will fix my issue…

    I will fine out monday!


    That is what I already proposed in my first answer, see

    Note: Using www.triplea-game.org/download you will get the latest release-candidate of the new 1.9 TripleA version.
    This version still has issues, especially when playing (continuing) games created with version and earlier.

    So if you want to continue, either do it with….
    Link is here, too: http://www.axisandallies.org/forums/index.php?topic=37791.msg1529827#msg1529827

    … or follow the upgrade notes to be found here: http://www.triplea-game.org/upgrade_notes

    Good luck :-)

Suggested Topics

  • 4
  • 6
  • 7
  • 3
  • 8
  • 3
  • 1
  • 30
Axis & Allies Boardgaming Custom Painted Miniatures