Alpha 3.9 Module compatible w/Battlemap 8.0?


  • Can someone point me to where the download is for the latest folder containing the files for Alpha 3.9 game compatible with Battlemap v8.0? My understanding is, all you have to do download and unzip the Alpha 3.9 folder into your Battlemap directory? Any help folks can lend would be greatly appreciated! Thanks!


  • I know there was a module up to the second version of A3.  I don’t know about this final one.
    However it’d be easy to just change some of the placements in the A2 module to be right.  The NOs aren’t too much different, and everything else is the same otherwise.  Convoys would just be one roll of dice to figure out.
    That is, if you want to use the new convoy system. 
    A bit over-complicated if you ask me.  :lol:


  • Yea, I agree w/the new convoy rules. Not sure if I like Alpha 2 or Alpha 3 better yet, as I haven’t played Alpha 3. But, I do know that w/out bidding that Alpha 2 was broken. In my opinion favored toward the Allies. Not sure why they didn’t just give the Axis a few more units or the Allies a few less and just stick w/Alpha 2. I think giving the Axis 6 to 8 more IPC’s would balance the game.

Suggested Topics

  • 40
  • 5
  • 9
  • 31
  • 3
  • 7
  • 14
  • 8
I Will Never Grow Up Games
Axis & Allies Boardgaming Custom Painted Miniatures
Dean's Army Guys

39
Online

15.3k
Users

36.5k
Topics

1.5m
Posts